Home Security

Security

Intermediary Root CA Certificate Expiration cPanel/WHM – Sectigo

On May 30, 2020 an intermediary CA certificate used by Sectigo expired causing some older versions of OpenSSL unable to validate the...